Программа «Кумир» написать алгоритмы

30 июня 2016 / Школа

Программа «Кумир» написать алгоритмы


комментария 2
  1. Аккаунт удален
    30 июня 2016 в 18:24 – Ответить
    Использовать Робот
    алг
    нач
    нц пока слева стена
      закрасить
      вверх
    кц
    нц пока справа свободно
      закрасить
      вправо
    кц
    нц пока справа стена
      закрасить
      вверх
    кц
    вниз
    кон

    использовать Робот
    алг 
    нач
    нц пока снизу свободно
      вниз
    кц
    нц пока снизу стена
      влево
    кц
    вниз
    нц пока справа свободно
      вправо
      если сверху стена то закрасить все 
    кц
    нц пока слева свободно
      нц пока клетка чистая
        если слева свободно то влево
          иначе стоп все
        нц пока клетка закрашена 
          нц пока снизу свободно
            вниз
            закрасить
          кц
          нц пока сверху свободно
            вверх
          кц
          влево
        кц
      кц
    кц
    кон

    использовать Робот
    алг
    нач
    нц пока справа свободно
      вправо
    кц
    нц пока справа стена
      вверх
    кц
    вправо
    нц пока снизу свободно
      вниз
      закрасить
    кц
    нц пока снизу стена
      закрасить
    вправо
    кц
    кон
  2. infor5
    30 июня 2016 в 18:24 – Ответить
    Кумир Решение  по схеме 1

Добавить комментарий